Back to overview
Degraded

Delayed processing

Sep 11 at 13:31 CEST
Affected services
Portal (app.cloudbilling.nl)

Resolved
Sep 11 at 13:53 CEST

Processing of background jobs has resumed.

Created
Sep 11 at 13:31 CEST

We're currently performing maintenance on background jobs processing. This will result in delayed processing of background jobs and invoice previews. We expect this maintenance to take up to 30 minutes.