Back to overview
Degraded
AWS customer mapping issue
Aug 29, 2024 at 9:32am UTC
Affected services
Portal (app.cloudbilling.nl)
Resolved
Aug 30, 2024 at 7:24am UTC
The issue has been resolved.
Affected services
Created
Aug 29, 2024 at 9:32am UTC
We are investigating an issue with AWS customer mappings. We have identified the cause and are working on a fix.
Affected services