Back to overview
Degraded

CloudBilling is not carrying out tasks

Jun 11, 2026 at 8:20am UTC
Affected services
Portal (app.cloudbilling.nl)

Resolved
Jun 11, 2026 at 9:02am UTC

We have identified and resolved the root cause of the issue. CloudBilling will now resume processing tasks. As a result, you may experience elevated system activity for a short period while these tasks are completed. We appreciate your patience and apologise for any inconvenience this may have caused.

Created
Jun 11, 2026 at 8:20am UTC

CloudBilling is currently not carrying out tasks. We are investigating and will provide regular updates.